FAQ: How to clear my browser’s cache?

Your internet browser’s cache stores certain information (snapshots) of webpages you visit on your computer or mobile device so that they’ll upload quicker. Occasionally, however your cache can prevent you from seeing updated content, or cause functional problems when stored content conflicts with live content. You can fix many browser problems simply by clearing your cache.

For further details check out this wikihow guide: 18 Ways to Clear Your Browser’s Cache 

FAQ: What is a browser and which browser am I using?

browsers 2
The browser is the program you are using to view this site. While most people use Microsoft’s Internet Explorer, Firefox and Google’s Chrome have big followings.  If you use a Mac, you might also use Safari. With so many to to choose from, people may be reluctant to try another brand, even when others claim the benefits of one over the other. Each one has its own advantages and disadvantages depending on what you are doing.

 What is a browser and what browser am I using?

How to update your browser version?

 How do I enable cookies on my browser?

FAQ: Updating your browser

Our moodle platform  and content within it has been designed in conjunction with Google Chrome. To view/use  the eLearning tools in your course, more efficiently you should use the latest version of Google Chrome.
However, this is still your choice, please see below to download the most common browsers.

Click here to view what browser version you are using and click the images below to download the latest versions.

GOOGLE CHROME                SAFARI                                   FIREFOX

Chrome     safari     firefox-logo.bee1d85af18f

FAQ: What is the recommended browser for Pathbrite?

If you are having any issues with Pathbrite, it could be that you are using an outdated version of Internet Explorer. Please try Firefox or Chrome as a browser.

Below you will find a list of the Pathbrite recommended browser versions.  Please note that if you use earlier versions of these browsers you are likely to run into issues when creating your portfolios.

Officially, Pathbrite recommends  the latest versions of each major browser. Click the browser name on the table below to download the latest versions.

Recommended Browsers Versions
Safari 5, 6 and 7
Chrome 28, 29 and 30
Firefox 22, 23 and 24
Internet Explorer 9, 10 and 11
Opera 15, 16 and 17

Click here to view what browser version you are using.

Click here for more detailed specifications of Pathbrite’s technical requirements.

FAQ: What are the minimum requirements to access my MCI moodle course?

Moodle can be accessed through a web browser on your PC, tablet or smartphone. Although smartphones and tablets enable you to browse the Moodle platform, be aware that to use its systems and eLearning tools they are not enough. Therefore, you need a personal computer (Windows Pc or Mac), a solid, reliable Internet connection, a modern web browser and some basic computer skills.

The system requirements for the Moodle user are modest and below are the minimum requirements (summary) that we would consider necessary for Moodle to run efficiently on your system and enable you to participate in your Montessori Centre International course effectively.

Skill Requirements
  • Basic computer skills:

Use of MSword or another word  processing program, compatible with MSword (compose, save and file management)

 E-mail and file management

  • Basic Internet skills:

Use a browser, search engines, downloading and uploading files

Familiarity with discussion boards and online forums

Technical Requirements
  • Recent Mac or PC machine with a current fully updated MSword operating system.

Our moodle courses have been designed using MSword as a word processing program, therefore you will need to have MSword  or a program that is compatible with it installed in your machine. If you do not have Microsoft Office, you can download Open Office which allows you to view and edit Microsoft Office files, and is available free for Windows and for non‐Windows computers. Furthermore, there is guidance on this site on how to export from other programmes (such as Pages or even Google docs) in to MSword.

You will also need  the following programs:

A PDF reader (Adobe Acrobat Reader is the most used on a PC and free to download). Mac machines already include Preview as a PDF reader.

Media player: Adobe Flash Player 
or QuickTime (in-built in Mac OX)

Microsoft Powerpoint  presentation software or another program compatible with it. Mac users can use the mac version or get Microsoft powerpoint for mac

  • A web browser with JavaScript enabled and Flash (Google Chrome browser already includes AdobeFlashPlayer built-in), and able to accept cookies. Current recommended minimum browsers include: latest Google Chrome, Mozilla Firefox and AppleSafari.

Click here to find out which browser you are using

  • Reliable internet connection, preferably broadband (DSL speeds) with bandwidth recommendation of minimum of 4mb download speed.

Click here to test your internet speed here

FAQ: Moodle recommended browser?

This post will familiarise you with the minimum recommended browser versions for your MCI moodle course.

Moodle is accessed through a web browser on your pc, tablet or smartphone. Moodle supports a variety of browser versions, and below you can see the minimum and recommended versions for the most common browsers. However, we do recommend our students to use the latest version of: Google Chrome, Mozilla firefox or Apple  Safari, to use/view the tools in your moodle platform most efficiently.

Click here to find out how to update your browser. new google

 *Internet Explorer 10 is required for drag-and-drop functionality within moodle

Like most of the world’s Web sites and browser producers, moodle encourages you to keep your browsers current to improve security and functionality. Most internet browsers will prompt you when updates are available. Be sure to install the updates when prompted to do so.